Locking onto a network is a NIGHTMARE



  • I write this post after meticulously checking and comparing phones from various company’s against Mark1 and its really disheartening to say that Mark1 scores the lowest when it comes to picking up a network.It takes forever to search for a network ,while other phones in the same location pick up network in seconds.

    This has been happening from day 1, however I just did not bother about it thinking that an update would fix this concern.
    The weirdest part is when the phone shows a 3G connection and when I open a browser page it says I’m not connected to the net.It takes 10 to 15 times just to get to the google page.
    While the same 3G connection on other phones works like a charm ( eg- Sony z5, Samsung note4, Samsung a7). These phones pick up network in no time compared to mark1.

    Mark 1 also seems to have a liking for 2G, as that’s what shows up most of the time while data is on. While other phones are really fast and lock onto 3G allowing me to surf the net quicker.
    I have also tried searching for a network while being connected to 3G and Mark1 finds it really hard to get network and takes forever.

    What’s the point in having a phone that’s well built when it does not cater to basic stuff like getting network locked ,connecting to the web,apart from being sluggish and hanging up on you while browsing.

    I really think the CREO team needs to address this issue with utmost importance as it just dampens the main reason of having a smart phone.

    I feel really let down at this point and have decided to put this phone away in its box for now and start using my spare phone.



  • @sai-srinivas …have complained as well…no resolution so far…strange !!!



  • @chrispaddy i think they are busy fixing it and providing the update this Month let’s see after this update…



  • It’s disheartening to see @CREO-Team has not responded to this issue, despite it being highlighted in several threads by several users.

    It’s at least decent to say you’ll are on it. It’s warranted on your part to post your findings.

    Leaving these critical bugs unchecked will dampen all the hype behind realising new features every month. It kills the USP of this phone

    @Product-Team @administrators @sai-srinivas


  • CREO Support

    @raHyM-aHMeD Hi, Sorry for inconvenience, we can understand your pain. This is absolutely an abnormal behavior of your Creo Mark 1. Please reach us to our support immediately at support@creosense.com or call us 1800-208-2736



  • @Sober-Barik no no really this happens in mine and others too phone seems to love 2g most of time it’s 2g, no network fault of sim



  • @CREO-Support @sai-srinivas …this is exactly what i am saying…they refuse to even acknowledge the prob



  • @Sober-Barik How is this aberrant behaviour when several users have complained about it?

    Since the 1st week of MAY, users have complained of network lock and other network related issues. Everyone is expecting a bug fix. Are you sure, giving a call to support is theonly way out?



  • its working pretty fine in my mark 1



  • I do see this problem… Especially while on “Roaming”… For example My Airtel-AP SIM doesn’t catch Network while in cousin’s place in Bengaluru (Location near BSK 2 stage)… While it catches full N/w and good 3G speeds when I move the SIM to my old Micromax Canvas4 phone… The only way to get around this is goto Airplane mode, then come back (Alternatively reboot/power cycle), then “Manually” Set the Network as Airtel 2G/3G… which in my opinion is not expected as this is a basic behavior of any android phone ( Read “Search Automatically” in the settings)



  • @kkrishnadeepak i know this method airplane method and by this method i use 3g


  • Product Team

    The root cause analysis for this issue is being done by the concerned department. It will be fixed soon.



  • @Ravi-Ranjan who told u and that’s a good news😮😀😁


  • Product Team

    @raHyM-aHMeD I tried to reproduce the steps, and found out that this is more related to network providers. When I am in an area, where only 2G connection is available, then my Mark1 shows E or 2g connection. But as soon as I go to an area with 3G / 4G coverage, my phone switches back to 3G/4G mode and works like charm. I tried with Airtel and Vodafone. Can you tell me, which is your network provider ?



  • @Ravi-Ranjan
    Did you try with a roaming Airtel SIM (mine was AP) in B’lore area interior to an apartment?? If you want I can show you around mine when I’m there next week; Not only talking about Data E/3G … but also the normal phone N/w… Just take out the SIM put in any different mobile handset(tried with Nokia basic bar phone, MMX Canvas4, Samsung Duos) and you’ll see it locked to Network almost immediately. And when put the sim back to Mark-1… i’ll have to go manually set the Network as Airtel after taking a long amount of “searching delay”…

    Network locking seems to work the digital way… Full N/w or No Network…


  • Product Team

    @kkrishnadeepak Airtel is having some serious issue with their signal strength in many parts of Bangalore. I have already notified them about the same. So, it is mostly the issue with the service provider. Please check with them once.

    Also, let me know, if you face similar issue in AP ?



  • If it was Airtel Network provider issue (which is actually true in some other areas where the other mobiles failed too)… How did the other mobiles catch the phone network? (I’m actually typing about normal call… no “smart” features included here). Sure it is some h/w issue on M1, which may or may not have a s/w fix. But in order to “lock” to a network on Creo-mark1, i’ll have to run manual search multiple times (>5-6) and only then “1 stick” of n/w appears, while a similar try on other mobile handset doesn’t result in so bad(no) network in 1st try itself . When I’m on home N/w… I don’t see this issue, atleast didn’t hit that yet and no I don’t have non-AP sim to test.


  • Product Team

    @kkrishnadeepak please try to reproduce same issue with other network provider ( say Vodafone ) under similar condition and let me know, if issue persists. In that case, we will have to check for a fix.



  • Same issue persists with BSNL CellOne



  • I don’t have any idea about Bangalore network . But I live in Chennai and my sim card belongs to tamilnadu ( both are different network circles , “roming free though”) , and until I grant permission to my pH to access data while roaming none of the pHs will allow me access data ( just saying to give you the clear picture ).
    I don’t have any problems till date with my Network , I do ride bike a lot and I use handsfree to communicate over my pH , network swapping or stability works like a charm . .
    PS- Airtel network- 4g



  • @Ravi-Ranjan hi ravi…its the same issue with vodafone as well i have tried in Delhi , amritsar and mumbai…there is a loooooooong delay in network lock and many times have to lock manually… It also doesnt lock to 4g 3g easily…although defaults are set. You may want to test these conplaints out and check…its definitely an issue… It gets worse in roaming…locking in to data speeda is also a similar issue



  • @Ravi-Ranjan I currently use Aircel service & have also tried Bsnl in Mark1, however both show signs of slower response in Mark1 whether its with picking network ,locking onto it or even surfing the net. The phone switches onto 2g so frequently like second nature. While using the same service in other phones keeps me on 3g in turn enabling faster browsing speeds. I really wish the Creo team looks into this area of concern asap & emerges triumphant …my two cents



  • @Ravi-Ranjan I have a portable airtel 4g router at home which works flawless irrespective of the room I keep it.

    But Mark 1 fails to even detect airtel 4g signals.
    It mostly shows 3g, which also works only in 2 rooms. Moreover it often downgrades to 2g


  • Product Team

    @Pradeep-Jayabal@All Hi, nowadays many mobile networks are taking third party services to ensure proper data / network connectivity. But any phone treats this as a roaming network ( mostly ), so the best practice to get flawless connectivity, make sure you go to settings ->More->Cellular Networks -> and set Data Roaming “ON” for both sims.



  • @Ravi-Ranjan seems you’ve misunderstood what I said . I don’t have any issues with network or data . I just said that I live in a roming circle but still network is perfect


  • Product Team

    This post is deleted!


  • @Sober-Barik This has happened with me also, and a lot of other people. So it cannot be treated as abnormal behaviour. The network by default fixes onto Edge connectivity. I have to switch on Aeroplane mode for a few seconds and then switch it off so that the phone can choose 3g/4g connectivity at the second attempt. Only then, the phone latches on to 3g mode properly. However, after some time, it again reverts back to Edge. This has happened in multiple areas in the city, so it cannot be a problem of my area.



  • @saikatsakura yeah he is right



  • Hey guys i got a solution
    First dial ##3646##
    Then before that go to settings change network type to 3g option then dial this and go to phone information and change network to wcdma only then close it
    That’s it i am perfectly on 3g no 2g sign i saw for days😏



  • How to set wcdma in Mark 1…please help me with step by step …


  • ADMIN

    @VGSNEZHIL please head over to reFuel app > Support and chat with our support team, they will help you with this.