Mark 1 is not getting connected with my Lappy



  • Hey Guys, I am unable to connect my Mark 1 to my Lappy, It is showing the USB Device not recognized.
    Please guide.


  • ADMIN

    @Shaikh-Abu-Sofiyan Are you using Macbook or a Windows machine?



  • Windows.


  • CREO Support

    @Shaikh-Abu-Sofiyan Hi ,

    Restart your Mark 1 and your Laptop
    This may sound too trivial and simple but it actually helped in some cases. If you’ve been using your computer or Android phone for a long time without restarting, they may be simply overloaded.

    That’s why the first thing to do is to restart your laptop and then restart your Mark 1.

    **Update your phone **
    Sometimes there may be some bugs in the software and updating your Mark 1 fuel version may indeed help.

    Update your computer
    Sometimes outdated system (most often Windows) will not recognize any Android device (or any USB device).
    That’s why it’s always a good idea to update your system. Remember not to install too many updates at the same time (not more than two or three), though.

    Use debug mode
    In most cases when nothing works, this method DOES work. This is the mode intended for developers. It allows you to directly access your phone, transfer and install apps without notification. To activate debug mode, go to Settings > Developer options > and check USB debugging.

    And last, also check, Is your USB cable OK?



  • Tried all the above listed steps yesterday as well as now but the same problem still exist. It is showing the same notification of “USB Not Recognized” at more than 3 PC’s at my office. (Tried on Windows 7,8,10)



  • @Shaikh-Abu-Sofiyan try with some other cable



  • @Shaikh-Abu-Sofiyan go to device manager in computer and click update driver.



  • Mark 1 is getting connected to the PC with another USB cable, suggest me CREO .


  • CREO Support

    @Shaikh-Abu-Sofiyan Hi, Happy to hear this, please reach out to Creo Support to claim your USB warranty at support@creosense.com or call 1800-208-2736