[ROM] Custom FlyMEOS 6.6.11.30 for MARK-1 with TWRP Recovery 3.0.2



  • Hello

    .
    Full Custom ROM FlyMEOS 6.6.11.30 + TWRP recovery package is available for download.

    .
    Such package can help CREO MARK-1 users to :

    • Enjoy FlyME User Experience & Services without having a MEIZU device.

    • Install additional modules and/or frameworks (such as Xposed) thanks to additional custom TWRP recovery + SuperSU root.

    .
    This is an announcement thread. For development discussions / questions please refer to the following thread :

    .
    ======================= DISCLAIMER ===========================

    The usual stuff :

    This package might be most suitable for experienced users but everybody is welcome to use it at his own risk.

    Flashing / Rooting your phone and using software tools have risks indeed = if instructions aren’t followed you can BRICK YOUR DEVICE. Therefore please read carefully all of the instructions & follow them if You choose to go on at your own risk.

    If You don’t understand the instructions stop & search on Google/Boards/XDA/etc. and / or ask for help.

    All the mentioned software & tools belong to their respective owners/developers. Neither I nor the owners / developers are not to be held responsible if you damage or brick your device.

    .
    ===================== REQUIRED ACTIONS =========================

    Follow provided instructions to flash ROM & restore IMEI of SIM1/SIM2. Then follow these steps :

    • Go into Settings \ Battery , select Low Power Mode - untick Turn Off Network and enable it.

    • Go into Settings \ Accessibility \ SmartTouch and enable it. Then set an action to perform Home Screen (only Back capacitive button has been mapped/enabled - You can use bottom->top swipe gesture to open task manager or set an action in SmartTouch settings).

    • Reboot into TWRP recovery (1) , install SuperSU, then do Wipe Dalvik / Cache & reboot.

      (1) On unrooted devices TWRP recovery can be started only from ADB (adb reboot recovery command - USB Debug must be enabled in Settings \ Developer Options). On rooted devices You can install & use QuickReboot .

    • Tap on SuperSU and initialize it.

    • Tap on App Store and search / download Google Installer.

    • Launch GMS Installer and install Google Framework + Play Services + Play Store

    .
    ========================= LINKS ===============================

    - Folder 99_L_ROM_FLYMEOS_61130
    - https://mega.nz/#F!UsAE0YQZ!-wb-2r6NxxcmBpDcVuRFxg!s0xHwAxC (Main Repo)

    - NeedROM Page
    - https://goo.gl/a8spTH

    .
    0_1482716703947_00_S61223-100516.jpg



  • @Raw-Main great



  • @Raw-Main bro how to flash this step by step instructions please.



  • This looks so exciting. I am really looking forward to this.



  • Hello

    @Girija-Das as usual I’ve provided instructions + drivers / tools / APKs together with the ROM package ;).

    You can find everything in 99_L_ROM_FLYMEOS_61130 folder .

    .
    0_1482755682916_2016-12-26.png



  • @Raw-Main wont it affect performance?and audio output without earphone is.not good its awseome btw thanks man



  • @Raw-Main and sd card storage have some problem.i guess coz in uc i select sd card it showed error while.downloading shows error.not available



  • Hello

    @Girija-Das I’ve already replied on dedicated ROM development thread at :

    Read & follow provided instructions = there are 6 required steps - section 4. After Installation - and for instance first one is just what solves notification shade issues.

    By the rest, there is no need to go on duplicating questions/answers = for development/technical questions it’s better to use the other thread in Android Tips section ;).



  • @Raw-Main yeah i got it i edited my question



  • Hello

    @Girija-Das SD card gets detected fine from File Managers & other programs (such as multimedia).

    Enabling Low Power Mode with unticked Turn Off Network is not affecting so much performance = it’s true that Antutu for instance returns 3k points less, but User Experience is quite the same.

    .
    I haven’t tried UC Browser (if that is the program with such SD issue). I’ll test it tomorrow & let you know.

    Meanwhile, Thanks for your feedback ;).



  • @Raw-Main thanks.bro another thing is led light is.not on while charging
    and any way.to.use home button.without floating ball



  • Hello

    Tell me if You’re having led issues while charging even after reboot and power-off = with L861 (that uses same settings & libraries for LED) after applying post-installation steps I had a similar issue, but it was indeed solved after first switch off of the device.

    .
    About Home button issue, MARK-1’s & L861’s capacitive buttons don’t support pressure levels as MEIZU’s physical button, so I’ve tried to map single actions to capacitive buttons.

    However, when I was mapping home capacitive button it behaved really buggy = it worked seldom, and most of time I’ve ended with all capacitive buttons (including back one) that weren’t working at all.



  • @Raw-Main bro only back.button.is working fine but not any button if i try gravity box will it work?
    and charging it doesnt charges nicely when.phone.is on it charges like 2% every 10 min but nicely charges when switched off like1% every 2mins and led works.only when.phone is switched off and when.its charging switched off it doesnt shows charge when.power key is pressed battery backup is.similar like stock



  • Hello

    @Girija-Das By default I’ve indeed mapped only back capacitive button because it was the only one working without any bug/issue.

    About Xposed Gravity Box module, I suggest You to try it & let us know ;) = today I don’t have time to test it, so I’ve just added to SD Pack folder a .zip package containing compatible Xposed Framework Installer + Gravity Box.

    Thanks again for all your valuable feedbacks ;).



  • @Raw-Main thanks.man for listening to our queries with patience and.giving a solution and.another.thing is that off screen.gestures not working as it was ealier there in stock and any solustion for charging when on? i will try it tomorow and tell u😉



  • Hello

    @Girija-Das You’re welcome & thanks again for your collaboration.

    I had to fully disable screen-off gestures support because of “weird” side effects = device was keeping on waking up accidentally when in a pocket or bag, leading to wrong PIN / Unlock situations.

    Unfortunately - according to what You’ve written on development thread - last MARK-1 official update hasn’t brought any kernel difference/improvement, that could be useful for Custom development/testing.

    .
    About LED behaviour, after installing Xposed Framework + GravityBox module, you may check if situation changes by overriding default LED policy = switching LED Battery Charge from Default to Always Enabled.



  • @Raw-Main okay bro the link that u used earlier today ta



  • @Raw-Main sometimes bro.net speed is.0 for sometime and after that its normal i exprienced it earlier today twice and that xposed i will directly flash it and clear cache?



  • @Raw-Main and is volte supported?if not how to get it?battery is not good drains nicely😅



  • Hello

    @Girija-Das are you experiencing such speed fluctuations with any particular program, even switching connection between WiFi and Mobile 3G/4G ?

    .
    About Xposed, after following after-installation steps, You have already installed SuperSU & device is rooted = Therefore You can download the Xposed Framework installer from MAIN Repository on MEGA (99_L_ROM_FLYMEOS_61130 - 04_SD_PACK) & install extracted APK normally from system without having to reboot to recovery & wipe.

    It will ask you only to grant SuperSU, download last update & reboot after installation.



  • Hello

    @Girija-Das check in your Mobile Settings menu & let me know = I’ve used Chinese (not Global) build also in in order to have VoLTE support enabled & it worked on L861 with Italian 4G Vodafone SIM VoLTE service.

    Tomorrow, once I finish some other tests I’m performing with L861 (now I’m checking feedbacks/reports by users of such device), I’m reflashing FlyME.



  • Hello

    First of all thanks @Girija-Das for the feedbacks You’re providing = even though I’m developing on L861 (MARK1’s HW twin-device) there are some little differences related to libraries/settings. Therefore - in order to change/improve custom ROM’s settings & apply bugfixes - Your feedbacks are really valuable.

    .

    • 1. Since L861 & MARK1 have same libraries/settings for capacitive buttons management I’ve tried again changing build/rom settings in order to map home and multitasking capacitive buttons. I’ve also used Xposed Module GravityBox to set manually related actions for pressure / long-pressure / double-tap of every capacitive hw button.
      .
      No way = still getting bugged responses of capacitive buttons, that even fully stop working after a while since boot.
      .
      Therefore I had to map again only back button -> then, I’ve used Xposed GravityBox ‘Navigation keys actions’ Menu to set for Back key :
      ‘Go Back’ as Single-Tap action
      ’Go Home’ as Long-Press action
      .
      0_1482798858638_S61227-01191582.jpg
      .
      Such settings allow indeed to get rid of SmartTouch (multitasking action can be performed through swipe bottom->top FlyME gesture).

    .

    • 2. on L861 I have LED working OK with same libraries/policies used by MARK1 (same that I’ve ported on FlyME ROM) = I’m going to check on L861 what happens using FlyME default libraries/policies. If everything OK I’ll repack a new system.img that You can try.

    .

    • 3. Into Settings \ Notifications & Status Bar I’ve enabled ‘Display Network Speed’ on Status Bar. I’ve checked that FlyME Data Saver wasn’t enabled (quick settings into notification shade) because it can lead to issues with UC’s & Opera’s data saving settings.
      .
      I’ve installed latest UC full build & I haven’t found any bug/issue neither with SD Card choice nor with speed on WiFi / Mobile.
      .
      0_1482798907071_S61227-01313888.jpg

    .

    • 4. I’ve just noticed battery drain while performing all those required after-installation steps & reboots + tests = yet, once finished, its’ consumption returned to acceptable values for daily average usage (i.e. web-browsing, downloads, videos, some gaming).
      .
      Now I’m charging battery up to 100%, then tomorrow I’ll check battery consumption again during my daily usage.


  • @Raw-Main ok bro no volte is there and charging led is not there when on
    speed is awseome.in this rom the thing is sometimes for 2min speed is.0kbps even.though.network.is.there but returns to normal after that random
    and baterry drains really like 1% every 2mins😭doing or nothing
    and uc i shall check it again



  • This post is deleted!

Log in to reply